Error while running

This topic contains 3 replies, has 2 voices, and was last updated by  admin 9 months, 1 week ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #261

    kopaszn
    Participant

    I got an error while training. I tried to change the basic logic, that changed “Bar Price” input of “Lin reg” predictor with “return U/D” and give this later the input of Bar price (similar to your earlier example in your tutorial video). Algominer freezes with message: “Input contains NaN, infinity or a value too large for dtype (float64)”. I tried to change shift and also the other value in “return U/D” but still no luck. What should I do?

    I would also like to know that is it possible to save history in Algominr so I dont have to import from scratch when I restart the app? It would save time.

    Is it possible not to use 1 minute data (only daily bars for example)?

    Can I connect to IB TWS (as I see possibility for such import).

    Thanks in advance.

    #262

    admin
    Keymaster

    Hi kopaszn

    this is because you get divisions by zero. Because the predictor node also creates a return series with standard settings, you will divide by 0 in some cases. So for you the quick fix would be to deselect ‘Predict change’ and ‘Discretize objective’ in the ‘Lin reg’ node.

    I will add some code to handle this case in the next update. Thanks for the report!

    At the moment you can’t connect to IB yet, but it will come in a future update.

    • This reply was modified 9 months, 2 weeks ago by  admin.
    #282

    kopaszn
    Participant

    Thanks for the help! I have some new notices, questions:
    1. I noticed even in version 1.2.2 that i save the portfolio and when i open the app it will open the most recent portfolio but the portfolio contains only the basic strategy. At least the history files are imported.
    2. I notice that when i choose “combine” not always 2 input tree is opened, sometimes just in input. Do i make something differently?
    3. Is still csv import is possible as i think it was possible in the past? This could be good for importing other indicator data.
    Thanks for developing and sharing this!

    #283

    admin
    Keymaster

    1. I will have to check this out. Do you also see this problem when loading a project file=

    2. Yes, that is a known bug. If you only get one input, just change the combine node to another node (e.g. indicators node) and then change it back to the combine node. It should work again afterwards. I’ll fix it as soon as possible

    3. I decided to remove .csv import. If you need another indicator, let me know, I can easily add them.

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.