Got error when starting

This topic contains 11 replies, has 6 voices, and was last updated by  admin 3 months, 4 weeks ago.

Viewing 12 posts - 1 through 12 (of 12 total)
  • Author
    Posts
  • #186

    wowo
    Participant

    Hi Chris,

    I got error as below when starting algominr.exe on Windows 10. Do you have any idea how to solve it? Thanks!!!

    [INFO ] Logger: Record log in C:\Users\weiwei\.kivy\logs\kivy_17-08-22_2.txt
    [INFO ] Kivy: v1.9.1
    [INFO ] Python: v3.5.1 |Continuum Analytics, Inc.| (default, Feb 16 2016, 09:49:46) [MSC v.1900 64 bit (AMD64)]
    [INFO ] Factory: 179 symbols loaded
    [INFO ] Image: Providers: img_tex, img_dds, img_gif, img_sdl2, img_pil (img_ffpyplayer ignored)
    [INFO ] Text: Provider: sdl2
    [INFO ] OSC: using <thread> for socket
    [INFO ] Window: Provider: sdl2
    [INFO ] GL: GLEW initialization succeeded
    [INFO ] GL: OpenGL version <b’4.5.13397 Compatibility Profile Context 15.200.1045.0′>
    [INFO ] GL: OpenGL vendor <b’ATI Technologies Inc.’>
    [INFO ] GL: OpenGL renderer <b’AMD Radeon HD 7570′>
    [INFO ] GL: OpenGL parsed version: 4, 5
    [INFO ] GL: Shading version <b’4.40′>
    [INFO ] GL: Texture max size <16384>
    [INFO ] GL: Texture max units <18>
    [INFO ] Window: auto add sdl2 input provider
    [INFO ] Window: virtual keyboard not allowed, single mode, not docked
    [WARNING ] stderr: Traceback (most recent call last):
    [WARNING ] stderr: File “algominr.py”, line 31, in <module>
    [WARNING ] stderr: File “<frozen importlib._bootstrap>”, line 969, in _find_and_load
    [WARNING ] stderr: File “<frozen importlib._bootstrap>”, line 958, in _find_and_load_unlocked
    [WARNING ] stderr: File “<frozen importlib._bootstrap>”, line 664, in _load_unlocked
    [WARNING ] stderr: File “<frozen importlib._bootstrap>”, line 636, in _load_backward_compatible
    [WARNING ] stderr: KeyError: ‘kivy.garden.matplotlib’

    #189

    Philipp
    Participant

    Ok, i figured it out. You have to install python, pip, wheel, garden.

    #190

    wowo
    Participant

    Thanks. I already installed Anaconda 4.4. How can I let AlgoMinr know where Python is installed?

    Thanks

    #191

    Philipp
    Participant

    Not sure, i’m new into this. I just downloaded istaller from http://www.python.org, then i ran algominr and look at console to see what package it need, then i just google “kivy install” and follow steps there.
    In general i just run cmd and type there “python <commands>”

    #203

    Patreze
    Participant

    I have similar problem. Installed kivy, but no luck.

    [INFO ] Logger: Record log in D:\Algominr/log\kivy_17-10-26_5.txt
    [INFO ] Factory: 194 symbols loaded
    [INFO ] Image: Providers: img_tex, img_dds, img_sdl2, img_pil, img_gif (img_ffpyplayer ignored)
    [INFO ] Text: Provider: sdl2
    [WARNING] stderr: Traceback (most recent call last):
    [WARNING] stderr: File “algominr.py”, line 27, in <module>
    [WARNING] stderr: File “<frozen importlib._bootstrap>”, line 961, in _find_and_load
    [WARNING] stderr: File “<frozen importlib._bootstrap>”, line 950, in _find_and_load_unlocked
    [WARNING] stderr: File “<frozen importlib._bootstrap>”, line 646, in _load_unlocked
    [WARNING] stderr: File “<frozen importlib._bootstrap>”, line 618, in _load_backward_compatible
    [WARNING] stderr: KeyError: ‘kivy.garden.contextmenu’

    #204

    admin
    Keymaster

    Hi Patreze
    What I see in your output is only warnings, not necessarily any errors.

    Is this the content of log/kivy/kivy_17-10-26_5.txt ? Could you also post the content of errlog.txt and log.txt (in D:/Algominr/)

    Thanks a lot for getting back..

    #207

    admin
    Keymaster

    alright, I think I found the problem. I added the new version to the post (http://algominr.com/dl/Algominr_alpha_1-2-1.zip) let me know if that works for you.

    best

    #208

    Patreze
    Participant

    New version starting ok. Thank You.
    Starting to test this now.

    best

    #209

    admin
    Keymaster

    Great! Let me know how it goes or if you have any questions.

    #257

    yokinfx
    Participant

    I’ve been able now to run it. The MT4 connection, does it work during weekend, when the market is closed and no ticks are received?

    Thanks for your efforts!

    Are you planning to make this an open source project?

    #258

    kopaszn
    Participant

    Hi,
    I have kivy fatal error starting Algominr:
    GL: Minimum Open required OpenGL version (2.0) NOT found!
    OpenGl version detected: 1.1

    I have thinkpad laptop x201, and did upgrade my graphics driver with win 7_64. Still NO success (probably opengl is not suported by this laptop). Is it really necessary to have OpenGL 2? I guess I need to by a new laptop…
    Thanks for any help.

    • This reply was modified 3 months, 4 weeks ago by  kopaszn.
    #260

    admin
    Keymaster

    @yokinfx
    You should be able to import symbols, even on the weekend. It just needs to find the MT4 connection.

    @kopaszn
    It needs OpenGL to render the user interface. It should come with the Intel drivers.. but if that doesn’t work, I can’t really help you, sorry.

Viewing 12 posts - 1 through 12 (of 12 total)

You must be logged in to reply to this topic.